こんにちわ、C#大好きオオバです。

UnityのPlayer Settingsの.NET4.xに設定を変更すると、
Rider側が認識せずコンパイルエラー状態。

コード補完が効かなくなりました。

※ただし、Unity側は正常にコンパイルは通ります

Unityの設定画面で解決

UnityのPreferences -> Riderから
Override TargetFramework Versionにチェック。

4.6を入力すると正常に動くようになります。

RiderがUnityの.NET4環境を認識しない場合の対処法_0

Riderのバージョンアップで
このあたりがよしなに解決されることを祈ります。

オススメ記事
検証環境