こんにちわ、オオバです。

Flutterをビルドしたときに以下のようなエラーが出たときの対処法です。

e: Incompatible classes were found in dependencies.  
Remove them from the classpath or  
use '-Xskip-metadata-version-check' to suppress errors...  

Flutterをビルドしたときに👆のようなエラーが出るようになりました。

kotlinのバージョンが古い

調べてみるとkotlinのバージョンが古いことが原因でした。

修正前のバージョン : 1.3.50
👇
修正後のバージョン : 1.4.32

修正する場所

android/build.gradle を修正します。

buildscript {  
    // 修正箇所  
    ext.kotlin_version = '1.4.32'  

~~~略~~~  
期間限定 最大95%オフセール
効率UPメガバンドル開催中!最大95%オフ!!!
期間 : 11月1日午後15時59分まで
オススメ記事
検証環境
参考サイト